Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 05, 2025 - 10:10 CST
Scheduled
WellSky has identified an issue requiring immediate maintenance. We will perform this maintenance on Friday December 5th, 2025 from 10:00 AM to 11:00 AM (Central Time). During this time, The Solution will be unavailable for a few minutes at the beginning of the maintenance window and a few minutes at the end. We thank you for your patience.
We apologize for the inconvenience as we work to provide a better experience for our clients.
Posted Dec 05, 2025 - 10:08 CST
This scheduled maintenance affected: CarePort Connect.