Referral Management Performance Degradation
Resolved
This issue is now resolved. If you believe that you are still experiencing issues related to this, please contact our Support team.

Posted Jan 04, 2025 - 13:11 CST
Investigating
WellSky is investigating an issue causing degraded system performance and clients may have trouble logging into accounts or loading pages.

Next Update - within 30 minutes

Posted Jan 04, 2025 - 12:58 CST
This incident affected: CarePort Referral Management.