Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 08, 2025 - 20:00 CST
Scheduled
WellSky has identified an issue requiring immediate maintenance. We will perform this maintenance on Saturday, February 8th, 2025 from 8 PM CT to 4 AM CT. During this time, the solution will be unavailable.
We apologize for the inconvenience as we work to provide a better experience for our clients.
Posted Jan 28, 2025 - 16:21 CST
This scheduled maintenance affected: CarePort Discharge and CarePort Intake.